[Numpy-discussion] testing binary installer for OS X

Ralf Gommers ralf.gommers@googlemail....
Sat Feb 27 00:43:27 CST 2010


On Sat, Feb 27, 2010 at 2:33 PM, David Cournapeau <cournape@gmail.com>wrote:

>
> Sorry, I should have been clearer in the above quoted list. There were
> two issues with numpy 1.4.0, one caused by datetime, and one caused by
> other changes to growing structures. The second one is ok for most
> cases, but cython < 0.12.1 was too strict in checking some structure
> size, meaning any extension built from cython < 0.12.1 will refuse to
> import. There is  nothing we can do for this one.
>
> So the "plan" I had in mind was:
>  - release fixed numpy 1.4.1
>  - release a new scipy 0.7.2 built against numpy 1.3.0, which would be
> compatible with both existing 1.3.0 and the new 1.4.1
>
> Is this clearer ?
>
>
Yes that is clear. Would it make sense to first release scipy 0.7.2 though?
Then numpy 1.4.1 can be tested against it and we can be sure it works. The
other way around it's not possible to test. Or can you tell from the test
output I posted that it should be okay?

Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100227/7fe3033a/attachment.html 


More information about the NumPy-Discussion mailing list