[Numpy-discussion] 1.4.0 installer fails on OSX 10.6.2

neil weisenfeld weisen123@gmail....
Tue Jan 5 10:35:22 CST 2010


Hi all,

I'm having an odd problem with the package installer for numpy 1.4.0.
It complains:

numpy 1.4.0 can't be installed on this disk. numpy requires System
Python 2.6 to install.


I'm running a stock system with a stock python, so I'm not sure why
the test is failing.  Any ideas how to debug this?

Some info:

weisen@Neil-Weisenfeld-MacBook-Pro:~
[507]$ which python
/usr/bin/python

weisen@Neil-Weisenfeld-MacBook-Pro:~
[508]$ python
Python 2.6.1 (r261:67515, Jul  7 2009, 23:51:51)
[GCC 4.2.1 (Apple Inc. build 5646)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>>

weisen@Neil-Weisenfeld-MacBook-Pro:~
[509]$ ls -l /System/Library/Frameworks/Python.framework/Versions/Current
lrwxr-xr-x  1 root  wheel  3 Sep 22 17:49
/System/Library/Frameworks/Python.framework/Versions/Current@ -> 2.6



Thanks,
Neil


More information about the NumPy-Discussion mailing list