[Numpy-discussion] 1.4.0 installer fails on OSX 10.6.2

Pierre GM pgmdevlist@gmail....
Tue Jan 5 15:03:10 CST 2010


On Jan 5, 2010, at 3:45 PM, Eric Firing wrote:
> neil weisenfeld wrote:
>> Hi all,
>> 
>> I'm having an odd problem with the package installer for numpy 1.4.0.
>> It complains:
>> 
>> numpy 1.4.0 can't be installed on this disk. numpy requires System
>> Python 2.6 to install.
> 
> I think the problem is that the message is misleading; it should be 
> saying you need python from python.org, *not* the python that comes with 
> OSX.  

???
I have several versions of numpy installed on my Macbook (OS X 6), but only one Python (the one that comes with Apple). However, these versions are installed in different virtual environments.
Neil, could you give us more info about how you're trying to install it ? Have you tried to use the --user flag (ie, `python setup.py install --user`) ?



More information about the NumPy-Discussion mailing list