[Numpy-discussion] 1.4.0 installer fails on OSX 10.6.2

David Cournapeau cournape@gmail....
Tue Jan 5 19:07:26 CST 2010


On Wed, Jan 6, 2010 at 8:22 AM, David Warde-Farley <dwf@cs.toronto.edu> wrote:
>
> On 5-Jan-10, at 6:01 PM, Christopher Barker wrote:
>
>
>> As the 2.6 series is binary compatible, you can build a single
>> installer
>> that will work with both

I don't think that's true. 2.6.x are compatible with each other iif
they are built with the same compiler options. There are too many
differences between Apple python and the python.org python (dtrace, 64
bits support, compiler options, etc...) IMHO to make a compatible
installer for both versions worthwhile.

>> way he's done it is to put wxPython itself into /usr/local, and then
>> put
>> some *.pth trickery into both of the pythons: /System/... and /
>> Library/...
>>
>> It works fine, and I've suggested it on this list before, but I guess
>> folks think it's too much of a hack -- or just no one has taken the
>> time
>> to do it.

I don't think it worths it. .pth files will involve even more point of
failures, and it has the potential of breaking things in non obvious
ways.

I agree that the lack of 64 bits installer is an issue, but building
numpy on mac os x is not that difficult, and I think people who need
64 bits often are more knowledgeable. There are also solutions like
EPD and the likes, which support 64 bits.

David


More information about the NumPy-Discussion mailing list