[Numpy-discussion] 1.4.0 installer fails on OSX 10.6.2

David Cournapeau cournape@gmail....
Tue Jan 5 19:09:19 CST 2010


On Wed, Jan 6, 2010 at 9:18 AM, Christopher Barker
<Chris.Barker@noaa.gov> wrote:

> If distutils/setuptools could identify the python version properly, then
>  binary eggs and easy-install could be a solution -- but that's a mess,
> too.

It would not solve the problem, really. Two same versions of python
does not imply compatible python when C extensions are involved. In
current state of affairs, where python does not have a stable ABI, the
only workable solution is to target one specific python (or to build
your own as in EPD).

cheers,

David


More information about the NumPy-Discussion mailing list