[Numpy-discussion] Stupid question (at least coming from me it is)

Charles R Harris charlesr.harris@gmail....
Fri Jan 8 15:40:34 CST 2010


On Fri, Jan 8, 2010 at 2:13 PM, David Goldsmith <d.l.goldsmith@gmail.com>wrote:

> So, to get the new numpy.polynomial "sub-package," one has to update to 1.4
> (or is there a 1.3.x that has it)?  Thanks!
>
>
Yes.


> DG
>
> PS: my pressing need (another stupid question, at least coming from me):
> chebyshev.chebdomain = [0,1] or [-1,1]?  Thanks again!
>
>
chebyshev.chebdomain is the default chebyshev domain and is [-1,1]. Maybe it
needs a bettter name? Note that it is integer; that isn't required, but it
makes it compatible with other types like Decimal that don't mix with
floats. Another possibility is to make it a function so I can document it,
at present it is an ndarray. For normal work you should use the
chebyshev.Chebyshev class.

Let me know what particular problem you are looking at as it will be useful
to start putting some examples together. And I want to see what needs
improvement.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100108/257b962f/attachment.html 


More information about the NumPy-Discussion mailing list