[Numpy-discussion] TypeError: 'module' object is not callable

David Cournapeau david@silveregg.co...
Mon Jan 11 22:33:33 CST 2010


Jankins wrote:

> 
> What should I do? And I couldn't even successfully install scipy in 
> Ubuntu 9.10 neither by "easy_install" or "source compilation". I am so 
> desperate.

Don't use easy_install, and install from sources with python setup.py 
install, both numpy and scipy, after having installed the following 
packages:

sudo apt-get install gfortran python-dev libatlas-base-dev python-nose

Before doing so, you should remove both the build directories (rm -rf 
build in your source tree) and the previously installed numpy/scipy if 
any (in /usr/local/lib/python2.6/site-packages/ on Ubuntu 9.10).

You should then be able to test your installations doing something like:

python -c "import numpy; numpy.test(); import scipy; scipy.test()"

cheers,

David


More information about the NumPy-Discussion mailing list