[Numpy-discussion] Wanted: new release manager for 1.5 and above

Ralf Gommers ralf.gommers@googlemail....
Sat Jan 16 08:35:07 CST 2010


On Sat, Jan 16, 2010 at 10:17 PM, David Cournapeau <cournape@gmail.com>wrote:

> On Sat, Jan 16, 2010 at 9:59 PM, Ralf Gommers
> > You get Sphinx
> > 0.6.4 when you need 1.0 (I think), and doc generation fails because MPL
> can
> > not be found.
>
> You need matplotlib to build numpy doc I think - at least it used to
> be the case. Maybe it is not needed anymore. As I have matplotlib
> installed on my machine anyway, this has never been an issue for me.
>
> Yes MPL is needed. I have it installed and can build the docs manually. It
is just that inside the 'bootstrap' virtualenv MPL import fails because of
the --no-site-packages. Maybe it works for you because your MPL install dir
is on your PYTHONPATH?

Anyway, I think doc building got more robust, so I'll try to modify the
paver script to use my site-packages.

Cheers,
Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100116/f29cd4bb/attachment.html 


More information about the NumPy-Discussion mailing list