[Numpy-discussion] Wanted: new release manager for 1.5 and above

Charles R Harris charlesr.harris@gmail....
Sat Jan 16 09:49:06 CST 2010


On Sat, Jan 16, 2010 at 7:35 AM, Ralf Gommers
<ralf.gommers@googlemail.com>wrote:

>
>
> On Sat, Jan 16, 2010 at 10:17 PM, David Cournapeau <cournape@gmail.com>wrote:
>
>> On Sat, Jan 16, 2010 at 9:59 PM, Ralf Gommers
>> > You get Sphinx
>> > 0.6.4 when you need 1.0 (I think), and doc generation fails because MPL
>> can
>> > not be found.
>>
>> You need matplotlib to build numpy doc I think - at least it used to
>> be the case. Maybe it is not needed anymore. As I have matplotlib
>> installed on my machine anyway, this has never been an issue for me.
>>
>> Yes MPL is needed. I have it installed and can build the docs manually. It
> is just that inside the 'bootstrap' virtualenv MPL import fails because of
> the --no-site-packages. Maybe it works for you because your MPL install dir
> is on your PYTHONPATH?
>
> Anyway, I think doc building got more robust, so I'll try to modify the
> paver script to use my site-packages.
>
>
It would be useful to document the build environment and how you set it up,
along with any version dependencies you uncover.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100116/d5eb4b4b/attachment.html 


More information about the NumPy-Discussion mailing list