[Numpy-discussion] Warning on http://scipy.org/ about binary incompatibility ?

David Cournapeau david@silveregg.co...
Wed Jan 27 19:20:29 CST 2010


josef.pktd@gmail.com wrote:
> Can we/someone add a warning on the front page http://scipy.org/
> (maybe under news for numpy download) about incompatibility of the
> binaries on sourceforge of scipy <=0.7.1 with numpy 1.4.0 ?

It seems that it will be quite difficult to fix the issue without 
removing something (I tried to use datetime as user types, but this 
opened a can of worms), so I am (quite reluctantly ) coming to the 
conclusion we should just bite the bullet and change the ABI number (so 
that importing anything will fail instead of crashing randomly).

Something like numpy 1.4.0.1, which would just have a different ABI 
number than 1.4.0, without anything else.

cheers,

David


More information about the NumPy-Discussion mailing list