[Numpy-discussion] Warning on http://scipy.org/ about binary incompatibility ?

josef.pktd@gmai... josef.pktd@gmai...
Wed Jan 27 19:35:05 CST 2010


On Wed, Jan 27, 2010 at 8:20 PM, David Cournapeau <david@silveregg.co.jp> wrote:
> josef.pktd@gmail.com wrote:
>> Can we/someone add a warning on the front page http://scipy.org/
>> (maybe under news for numpy download) about incompatibility of the
>> binaries on sourceforge of scipy <=0.7.1 with numpy 1.4.0 ?
>
> It seems that it will be quite difficult to fix the issue without
> removing something (I tried to use datetime as user types, but this
> opened a can of worms), so I am (quite reluctantly ) coming to the
> conclusion we should just bite the bullet and change the ABI number (so
> that importing anything will fail instead of crashing randomly).
>
> Something like numpy 1.4.0.1, which would just have a different ABI
> number than 1.4.0, without anything else.

If you are also able to provide new scipy binaries, then at least the
combination would be usable without intermittent import errors and
crashes.

Would the change in the ABI numer prevent some other programs that use
numpy and are compiled against an older numpy, for me mainly
matplotlib, from running?

Josef


>
> cheers,
>
> David
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>


More information about the NumPy-Discussion mailing list