[Numpy-discussion] Warning on http://scipy.org/ about binary incompatibility ?

josef.pktd@gmai... josef.pktd@gmai...
Wed Jan 27 23:18:49 CST 2010


On Wed, Jan 27, 2010 at 8:38 PM, David Cournapeau <david@silveregg.co.jp> wrote:
> josef.pktd@gmail.com wrote:
>
>>
>> If you are also able to provide new scipy binaries, then at least the
>> combination would be usable without intermittent import errors and
>> crashes.
>
> The problem is that the new scipy would not be usable with older numpy.
> That's why breaking the ABI is so painful.
>
>>
>> Would the change in the ABI numer prevent some other programs that use
>> numpy and are compiled against an older numpy, for me mainly
>> matplotlib, from running?
>
> Not some, *all* of them (as long as they use the numpy C extension, that
> is - pure python are obviously unaffected).
>
> David
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>


More information about the NumPy-Discussion mailing list