[Numpy-discussion] Warning on http://scipy.org/ about binary incompatibility ?

David Cournapeau david@silveregg.co...
Thu Jan 28 00:39:57 CST 2010


Charles R Harris wrote:
> 
> 
> On Wed, Jan 27, 2010 at 6:20 PM, David Cournapeau <david@silveregg.co.jp 
> <mailto:david@silveregg.co.jp>> wrote:
> 
>     josef.pktd@gmail.com <mailto:josef.pktd@gmail.com> wrote:
>      > Can we/someone add a warning on the front page http://scipy.org/
>      > (maybe under news for numpy download) about incompatibility of the
>      > binaries on sourceforge of scipy <=0.7.1 with numpy 1.4.0 ?
> 
>     It seems that it will be quite difficult to fix the issue without
>     removing something (I tried to use datetime as user types, but this
>     opened a can of worms), so I am (quite reluctantly ) coming to the
>     conclusion we should just bite the bullet and change the ABI number (so
>     that importing anything will fail instead of crashing randomly).
> 
>     Something like numpy 1.4.0.1, which would just have a different ABI
>     number than 1.4.0, without anything else.
> 
> 
> Why do you think it would be better to make this change in 1.4 rather 
> than 1.5?

Because then any extension fails to import with a clear message instead 
of crashing as it does now. It does not matter much if you know the 
crash is coming from an incompatible ABI, but it does if you don't :)

cheers,

David


More information about the NumPy-Discussion mailing list