[Numpy-discussion] Warning on http://scipy.org/ about binary incompatibility ?

Charles R Harris charlesr.harris@gmail....
Thu Jan 28 15:17:29 CST 2010


On Thu, Jan 28, 2010 at 12:33 AM, David Cournapeau <david@silveregg.co.jp>wrote:

> Charles R Harris wrote:
> >
> >
> > On Wed, Jan 27, 2010 at 11:39 PM, David Cournapeau
> > <david@silveregg.co.jp <mailto:david@silveregg.co.jp>> wrote:
> >
> >     Charles R Harris wrote:
> >      >
> >      >
> >      > On Wed, Jan 27, 2010 at 6:20 PM, David Cournapeau
> >     <david@silveregg.co.jp <mailto:david@silveregg.co.jp>
> >      > <mailto:david@silveregg.co.jp <mailto:david@silveregg.co.jp>>>
> wrote:
> >      >
> >      >     josef.pktd@gmail.com <mailto:josef.pktd@gmail.com>
> >     <mailto:josef.pktd@gmail.com <mailto:josef.pktd@gmail.com>> wrote:
> >      >      > Can we/someone add a warning on the front page
> >     http://scipy.org/
> >      >      > (maybe under news for numpy download) about
> >     incompatibility of the
> >      >      > binaries on sourceforge of scipy <=0.7.1 with numpy 1.4.0 ?
> >      >
> >      >     It seems that it will be quite difficult to fix the issue
> without
> >      >     removing something (I tried to use datetime as user types,
> >     but this
> >      >     opened a can of worms), so I am (quite reluctantly ) coming
> >     to the
> >      >     conclusion we should just bite the bullet and change the ABI
> >     number (so
> >      >     that importing anything will fail instead of crashing
> randomly).
> >      >
> >      >     Something like numpy 1.4.0.1, which would just have a
> >     different ABI
> >      >     number than 1.4.0, without anything else.
> >      >
> >      >
> >      > Why do you think it would be better to make this change in 1.4
> rather
> >      > than 1.5?
> >
> >     Because then any extension fails to import with a clear message
> instead
> >     of crashing as it does now. It does not matter much if you know the
> >     crash is coming from an incompatible ABI, but it does if you don't :)
> >
> >
> > But why not remove the change?
>
> Because Travis was against it when it was suggested last september or
> so. And removing in 1.4.x a feature introduced in 1.4.0 is weird.
>
>
But wasn't that decision based on the premiss that the datetime work
wouldn't break the ABI? I don't see anything weird about making 1.4 work
with existing binaries. If we are going to break the ABI, and it looks like
we will, then it would be better if the word went out early so that projects
that depend on numpy can be prepared for the change. So my preference would
be to remove the incompatibility in 1.4 and introduce it in 1.5.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100128/353232fe/attachment.html 


More information about the NumPy-Discussion mailing list