[Numpy-discussion] OT: request help building pymex win64

Robin robince@gmail....
Fri Jul 2 11:58:49 CDT 2010


On Fri, Jul 2, 2010 at 5:47 PM, David Cournapeau <cournape@gmail.com> wrote:
>
> The problem may be that matlab is built with one runtime, and Python
> with another.... Unless your matlab is very recent, it is actually
> quite likely to be compiled with VS 2005, which means you should use
> python 2.5 instead (or built python2.6 with VS 2005, but I am not sure
> it is even possible without herculean efforts).

Thanks for your help!

I thought of that, but then VS 2008 is an officially supported
compiler for the version of matlab I am using (2009a).
http://www.mathworks.com/support/compilers/release2009a/win64.html

So I thought on the matlab/mex side 2008 should be fine, and I thought
since Python is built with 2008 that should also be OK.  But obviously
something isn't!

Cheers

Robin


More information about the NumPy-Discussion mailing list