[Numpy-discussion] Numpy 1.5 for Python 2.7 and 3.1

Pauli Virtanen pav@iki...
Sat Jul 3 12:09:21 CDT 2010


Fri, 25 Jun 2010 12:31:36 -0700, Christoph Gohlke wrote:
> at <http://projects.scipy.org/numpy/ticket/1520> I have posted a patch
> against numpy svn trunk r8464 that:
> 
> 1) removes the datetime functionality 2) restores ABI compatibility with
> numpy 1.4.1 3) enables numpy to build and run on Python 2.7 and 3.1 (at
> least on Windows)
[clip]

This should make it easier to keep track of it:

	http://github.com/pv/numpy-work/tree/1.5.x

I note that the patch contains some additional 3K porting. We/I'll need 
to split the patch into two parts:

- Py3K or other miscellaneous fixes that should also go to the trunk
- removing datetime and restoring the ABI

I can probably take a look on this during EuroScipy. I'd also like to 
manually check the diff to svn/1.4.x

So far, I think the following changes look like they should also go to 
the trunk:

- numpy/numarray/_capi.c
- numpy/lib/tests/test_io.py
- numpy/core/include/numpy/npy_math.h

-- 
Pauli Virtanen



More information about the NumPy-Discussion mailing list