[Numpy-discussion] numpy 1.5 or 2.0

Pauli Virtanen pav@iki...
Mon Jul 19 07:47:14 CDT 2010


ma, 2010-07-19 kello 15:10 +0300, Nadav Horesh kirjoitti:
> Till now I see that  numpy2 plays well with PIL, Matplotlib, scipy and
> maybe some other packages. Should I expect that it might break?

If the other packages are compiled against Numpy 1.4.1 or earlier, then
yes, they are expected to break.

If you compile them against Numpy 2.0.0, they still work -- the API will
still be the same.

	Pauli




More information about the NumPy-Discussion mailing list