[Numpy-discussion] numpy 1.5 or 2.0

Nadav Horesh nadavh@visionsense....
Mon Jul 19 07:48:32 CDT 2010


Got it.

  Thank you very much,

   Nadav


-----Original Message-----
From: numpy-discussion-bounces@scipy.org on behalf of Pauli Virtanen
Sent: Mon 19-Jul-10 15:47
To: Discussion of Numerical Python
Subject: Re: [Numpy-discussion] numpy 1.5 or 2.0
 
ma, 2010-07-19 kello 15:10 +0300, Nadav Horesh kirjoitti:
> Till now I see that  numpy2 plays well with PIL, Matplotlib, scipy and
> maybe some other packages. Should I expect that it might break?

If the other packages are compiled against Numpy 1.4.1 or earlier, then
yes, they are expected to break.

If you compile them against Numpy 2.0.0, they still work -- the API will
still be the same.

	Pauli


_______________________________________________
NumPy-Discussion mailing list
NumPy-Discussion@scipy.org
http://mail.scipy.org/mailman/listinfo/numpy-discussion

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/ms-tnef
Size: 2964 bytes
Desc: not available
Url : http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100719/df966c76/attachment.bin 


More information about the NumPy-Discussion mailing list