[Numpy-discussion] segmentation fault when installing with pip and python2.7

Ralf Gommers ralf.gommers@googlemail....
Sat Jul 24 01:44:31 CDT 2010


On Fri, Jul 23, 2010 at 11:46 AM, celil <celil.kj@gmail.com> wrote:

> Hello,
>
> I just installed numpy on Snow Leopard using pip. However, running the
> tests results in a segmentation fault. Has anybody else encountered this
> problem? How did you solve it?
>
> Do not use pip or easy_install, these tools are not very reliable. This
question gets asked very regularly, and just plain "python setup.py install"
usually solves the problem.

Besides that, you're using python 2.7, so you have to compile numpy trunk or
1.5.x branch, 1.4.1 does not work.

Cheers,
Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100724/be84affc/attachment.html 


More information about the NumPy-Discussion mailing list