[Numpy-discussion] segmentation fault when installing with pip and python2.7

Benjamin Root ben.root@ou....
Sat Jul 24 13:39:49 CDT 2010


On Sat, Jul 24, 2010 at 1:44 AM, Ralf Gommers
<ralf.gommers@googlemail.com>wrote:

>
>
> On Fri, Jul 23, 2010 at 11:46 AM, celil <celil.kj@gmail.com> wrote:
>
>> Hello,
>>
>> I just installed numpy on Snow Leopard using pip. However, running the
>> tests results in a segmentation fault. Has anybody else encountered this
>> problem? How did you solve it?
>>
>> Do not use pip or easy_install, these tools are not very reliable. This
> question gets asked very regularly, and just plain "python setup.py install"
> usually solves the problem.
>
> Besides that, you're using python 2.7, so you have to compile numpy trunk
> or 1.5.x branch, 1.4.1 does not work.
>
> Cheers,
> Ralf
>
>
I have to wonder why this question keeps coming up.  Do we need to make the
build/installation instructions on the website clearer?  Maybe explicitly
state which common methods of installing python tools should and should not
be used?

I am not quite familiar with pip and such, but could there be some way to
have the numpy package on PyPi return a message saying that one should build
from source instead?  Or is there something that can be done to make
installing using pip better?

Ben Root
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100724/20aa9ae5/attachment.html 


More information about the NumPy-Discussion mailing list