[Numpy-discussion] segmentation fault when installing with pip and python2.7

Benjamin Root ben.root@ou....
Sat Jul 24 16:21:08 CDT 2010


On Sat, Jul 24, 2010 at 2:38 PM, David Cournapeau <cournape@gmail.com>wrote:

> On Sun, Jul 25, 2010 at 3:39 AM, Benjamin Root <ben.root@ou.edu> wrote:
>
> > I have to wonder why this question keeps coming up.
>
> In general, because the packaging/build infrastructure in python is
> horrible.
>
> However, in this precise case, the issue is simply that numpy 1.4.1
> does not support python2.7.
>
> cheers,
>
> David
>

Hmm, maybe I should phrase my question differently...  I meant to ask is if
there is some way that we could

1) better discourage the use of these methods
2) improve the error messages of failed installation attempts to help users
(maybe have a particular webpage available with FAQ regarding installation
issues and have that URL printed in the case of an installation failure)?

The idea being that we might be able to better head-off these questions to
the mailing list by providing a better resource for dealing with
installation issues, and to have this resource available at the user's
fingertips.

Ben Root


> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100724/a8c6e49b/attachment.html 


More information about the NumPy-Discussion mailing list