[Numpy-discussion] Numpy installation problem

Jonathan Tu jhtu@princeton....
Sat Jul 24 18:03:50 CDT 2010


>> Yes, you should be worried. To run the numpy tests you need to install
> nose. That's what your output said:
> 
> ImportError: Need nose >= 0.10.0 for tests - see
> http://somethingaboutorange.com/mrl/projects/nose
> 
> For h5py, you might want to try the h5py list. Did you remove the
> build directory? Because I don't know much about installation, I
> remove everything: the installed package, the build directory.

Thanks for the tip on nose.  I installed it, and now I see that I have 5 numpy failures:

======================================================================
FAIL: test_lapack (test_build.TestF77Mismatch)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/testing/decorators.py", line 146, in skipper_func
    return f(*args, **kwargs)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_build.py", line 48, in test_lapack
    information.""")
AssertionError: Both g77 and gfortran runtimes linked in lapack_lite ! This is likely to
cause random crashes and wrong results. See numpy INSTALL.txt for more
information.

======================================================================
FAIL: test_cdouble (test_linalg.TestEigh)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 221, in test_cdouble
    self.do(a)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 259, in do
    assert_almost_equal(ev, evalues)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 23, in assert_almost_equal
    old_assert_almost_equal(a, b, decimal=decimal, **kw)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/testing/utils.py", line 437, in assert_almost_equal
    "DESIRED: %s\n" % (str(actual), str(desired)))
AssertionError: Items are not equal:
ACTUAL: [-4.48116078  3.37176039]
DESIRED: [-2.60555128+0.j  4.60555128+0.j]


======================================================================
FAIL: test_csingle (test_linalg.TestEigh)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 217, in test_csingle
    self.do(a)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 259, in do
    assert_almost_equal(ev, evalues)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 23, in assert_almost_equal
    old_assert_almost_equal(a, b, decimal=decimal, **kw)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/testing/utils.py", line 437, in assert_almost_equal
    "DESIRED: %s\n" % (str(actual), str(desired)))
AssertionError: Items are not equal:
ACTUAL: [-4.48116064  3.37176037]
DESIRED: [-2.60555124+0.j  4.60555124+0.j]


======================================================================
FAIL: test_cdouble (test_linalg.TestEigvalsh)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 221, in test_cdouble
    self.do(a)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 249, in do
    assert_almost_equal(ev, evalues)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 23, in assert_almost_equal
    old_assert_almost_equal(a, b, decimal=decimal, **kw)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/testing/utils.py", line 437, in assert_almost_equal
    "DESIRED: %s\n" % (str(actual), str(desired)))
AssertionError: Items are not equal:
ACTUAL: [-4.48116078+0.j  3.37176039+0.j]
DESIRED: [-2.60555128+0.j  4.60555128+0.j]


======================================================================
FAIL: test_csingle (test_linalg.TestEigvalsh)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 217, in test_csingle
    self.do(a)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 249, in do
    assert_almost_equal(ev, evalues)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/linalg/tests/test_linalg.py", line 23, in assert_almost_equal
    old_assert_almost_equal(a, b, decimal=decimal, **kw)
  File "/home/jhtu/local/lib/python2.6/site-packages/numpy/testing/utils.py", line 437, in assert_almost_equal
    "DESIRED: %s\n" % (str(actual), str(desired)))
AssertionError: Items are not equal:
ACTUAL: [-4.48116064+0.j  3.37176037+0.j]
DESIRED: [-2.60555124+0.j  4.60555124+0.j]


----------------------------------------------------------------------
Ran 2483 tests in 15.250s

FAILED (KNOWNFAIL=4, failures=5)
<nose.result.TextTestResult run=2483 errors=0 failures=5>

The first seems to be linked to g77 vs gfortran.  I used g77 to install lapack.  I thought that when I installed numpy, it would use the g77 compiler by default...but maybe this is not the case?  Perhaps it also caused the other 4 errors?

And thanks for the tip, I will try the h5py list for those tests.



Jonathan Tu



More information about the NumPy-Discussion mailing list