[Numpy-discussion] segmentation fault when installing with pip and python2.7

Peter numpy-discussion@maubp.freeserve.co...
Sun Jul 25 06:38:41 CDT 2010


On Sat, Jul 24, 2010 at 8:38 PM, David Cournapeau  wrote:
>
> In general, because the packaging/build infrastructure in python is horrible.
>
> However, in this precise case, the issue is simply that numpy 1.4.1
> does not support python2.7.
>

How about a tiny update to the numpy 1.4.x on PyPi which checks for
Python 2.7 and aborts with a message suggesting waiting for NumPy
1.5.x or using Python 2.6 instead?

Peter


More information about the NumPy-Discussion mailing list