[Numpy-discussion] module compiled against ABI version 2000000 but this version of numpy is 1000009

Peter Schmidtke pschmidtke@mmb.pcb.ub...
Thu Jul 29 11:45:38 CDT 2010


Hi all,

I am trying to install manually the latest releases of scipy and numpy on Mac OSX 10.6 Snow Leopard. I previously used the dmg installer that is available, but the numpy version is too new for some other modules I have and need on my machine, so I went for a manual install of numpy 1.4 and scipy 0.8. 

I can import numpy without problems, but when I import scipy.cluster for example, I get an error message like : 

module compiled against ABI version 2000000 but this version of numpy is 1000009

I understand that both scipy and numpy are not compatible...but what numpy version should I use? I already use the newest release and I cannot go for the svn version as pycuda won't work as it should anymore. 

Thanks in advance for your lights on this.


Peter Schmidtke

-----------------
PhD Student
Department of Physical Chemistry
School of Pharmacy
University of Barcelona
Barcelona, Spain




More information about the NumPy-Discussion mailing list