[Numpy-discussion] Problems with get_info installing scipy

Pauli Virtanen pav@iki...
Tue Jun 8 09:41:53 CDT 2010


Tue, 08 Jun 2010 09:47:41 -0400, Jeff Hsu wrote:
> I tried to install scipy, but I get the error with not being able to
> find get_info() from numpy.distutils.misc_util.  I read that you need
> the SVN version of numpy to fix this.  I recompiled numpy and
> reinstalled from the SVN, which says is version 1.3.0 (was using 1.4.1
> version before) and that function is not found within either versions. 
> What version of numpy should I use? Or maybe I'm not removing numpy
> correctly.

It's included in 1.4.1 and in SVN (which is 1.5.x).

You almost certainly have an older version of numpy installed somewhere 
that overrides the new one. Check "import numpy; print numpy.__file__" to 
see which one is imported.

-- 
Pauli Virtanen



More information about the NumPy-Discussion mailing list