[Numpy-discussion] Error while upgrading to numpy 1.4.1

David Cournapeau cournape@gmail....
Mon Jun 14 01:09:36 CDT 2010


On Mon, Jun 14, 2010 at 3:00 PM, Vishal Rana <ranavishal@gmail.com> wrote:
> Hi,
> I am getting this error while upgrading to numpy 1.4.1 from 1.3 on ubuntu
> 10.04 using easy_install -U numpy command, I even tried downloading /
> installing numpy 1.4.1 but no luck, help appreciated.

First, do not use easy_install to upgrade the numpy included with
ubuntu. You should never do that, because easy_install will break the
state of your installed packages w.r.t. apt database.

It looks like you do not have development tools installed (the crt.o
is a C runtime file which is provided by gcc) - install gcc, gfortran
and libatlas-base-dev.

I would also strongly discourage you to use easy_install on 10.04. The
version in ubuntu 10.04 uses distribute which is buggier than
setuptools at this point (sic),

cheers,

David


More information about the NumPy-Discussion mailing list