[Numpy-discussion] f2py with 4.1 under snow leopard

Robert Kern robert.kern@gmail....
Wed Jun 16 12:01:01 CDT 2010


2010/6/16 Charles سمير Doutriaux <doutriaux1@llnl.gov>:
> Hi,
>
> I cannot build any f2py extension under nupmy 4.1 on Mac snow leopard.
>
> Everything (python/numpy) has been built 64bit.
>
> I'm attaching the log of a VERY simple piece of code, that always worked fine before.
>
> Any idea on why it's not finding the basic python things (Py_BuildValue for example?)

I'm guessing that you have defined the LDFLAGS environment variable.
When compiling Fortran extensions, LDFLAGS completely replaces the
link flags. It does not add to them. So the link flags that are
necessary for building a proper Python extension are lost.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
  -- Umberto Eco


More information about the NumPy-Discussion mailing list