[Numpy-discussion] Superpack - one Complex test failure

josef.pktd@gmai... josef.pktd@gmai...
Mon Mar 1 08:06:19 CST 2010


On Mon, Mar 1, 2010 at 8:40 AM, Ralf Gommers
<ralf.gommers@googlemail.com> wrote:
> Finally I got my Wine environment sorted out - I'm now able to build
> superpack installers for both Python 2.5 and 2.6. I tested the 2.6 installer
> on Windows XP, and got a single test failure. This exact same test also is
> the only test failure with the numpy 1.3 installer on sourceforge. So the
> installer seems fine to me, and either it's the machine on which I'm testing
> or this test just fails on windows. What do other people see when using an
> installer from Sourceforge?
>
> For completeness: the installed version is SSE3, processor is Intel Core Duo
> P8700.
>
>
> ======================================================================
> FAIL: test_special_values (test_umath_complex.TestClog)
> ----------------------------------------------------------------------
> Traceback (most recent call last):
>   File
> "C:\Python26\lib\site-packages\numpy\core\tests\test_umath_complex.py", l
> ine 179, in test_special_values
>     assert_almost_equal(np.log(x), y)
>   File "C:\Python26\lib\site-packages\numpy\testing\utils.py", line 437, in
> asse
> rt_almost_equal
>     "DESIRED: %s\n" % (str(actual), str(desired)))
> AssertionError: Items are not equal:
> ACTUAL: [ NaN+2.35619449j]
> DESIRED: (inf+2.35619449019j)
>
>
> ----------------------------------------------------------------------
> Ran 2342 tests in 8.000s
>
> FAILED (KNOWNFAIL=7, SKIP=1, failures=1)

This test has been reported to fail for a while on Windows. It also
fails with numpy 1.4.0

I don't have 1.3 or 1.4.1 available for testing right now.

Josef

>
> Cheers,
> Ralf
>
>
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
>


More information about the NumPy-Discussion mailing list