[Numpy-discussion] todos before 1.4.1 RC1

Ralf Gommers ralf.gommers@googlemail....
Mon Mar 1 08:52:27 CST 2010


Hi all,

Here are some requests / things I think need to be done before a 1.4.1 RC1
can be put out.

1. Bump up the version to 1.4.1
2. Update the release notes, including an explanation of why 1.4.0 was
pulled.
3. Patrick and I need info on how to upload to Sourceforge. David or Jarrod,
can you tell us how this works (offlist)?

I guess I can do 1 and 2, but I don't have commit rights. I'm happy to get
them, if you'd all prefer that I submit patches for a while first that's
fine too.

Then, I'm also going to try this once more: in my opinion we should not
release numpy 1.4.1 before scipy 0.7.2. Consider this:
numpy 1.3 + scipy 0.7.1 = OK
numpy 1.4.1 + scipy 0.7.2 = OK
numpy 1.3 + scipy 0.7.2 = OK
numpy 1.4.1 + scipy 0.7.1 = NOT OK (Cython issue)

So either release 1.4.1 and 0.7.2 at the same time, or scipy 0.7.2 first.
Even having an incompatible combination out there for a couple of days/weeks
is a bad idea imho.

Cheers,
Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100301/a584308b/attachment.html 


More information about the NumPy-Discussion mailing list