[Numpy-discussion] Snow Leopard Py-2.7a3 _init_posix issue; IO test segfault

Tom Loredo loredo@astro.cornell....
Mon Mar 1 14:04:10 CST 2010


Bruce Southey wrote:

On Fri, Feb 26, 2010 at 6:59 PM, David Warde-Farley <dwf@cs.toronto.edu> wrote:
> On 26-Feb-10, at 7:43 PM, Charles &#1587;&#1605;&#1610;&#1585; Doutriaux wrote:
>
>> Any idea on how to build a pure 32bit numpy on snow leopard?
>
> If I'm not mistaken you'll probably want to build against the
> Python.org Python rather than the wacky version that comes installed
> on the system. The Python.org installer is a 32-bit Python that
> installs itself in /Library.
>
> David
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
If you remain with 2.7 then you should also view the thread started 3 days ago:
'distutils problem with NumPy-1.4 & Py-2.7a3 (Snow Leopard)'
http://mail.scipy.org/pipermail/numpy-discussion/2010-February/048882.html

In particular:
Ticket 1355 - that should be resolved with r8260 (thanks Stefan):
http://projects.scipy.org/numpy/ticket/1355
Ticket 1409
http://projects.scipy.org/numpy/ticket/1409
Ticket 1345:
http://projects.scipy.org/numpy/ticket/1345

~~~~~~~~~~~~~~~~~~~~

Ticket 1409 indicates the _init_posix issue was fixed 5 days
ago, but as of today the unnecessary _init_posix reference
is still in the version available on SVN (r8270):

numpy-r8270:145$ time python setup.py build --fcompiler=gnu95
Running from numpy source directory.Traceback (most recent call last):
  File "setup.py", line 210, in <module>
    setup_package()
  File "setup.py", line 187, in setup_package
    from numpy.distutils.core import setup
  File "/Volumes/Tracking/Temp-work/Sandbox-installs/numpy-r8270/numpy/distutils/__init__.py", line 7, in <module>
    import ccompiler
  File "/Volumes/Tracking/Temp-work/Sandbox-installs/numpy-r8270/numpy/distutils/ccompiler.py", line 22, in <module>
    _old_init_posix = distutils.sysconfig._init_posix
AttributeError: 'module' object has no attribute '_init_posix'

Per Robert's suggestion, I commented out the offending line (22)
in ccompiler.py, and the build proceeded.  I am using a 64-bit
universal build.  The resulting numpy gives a segfault on test:

>>> numpy.test(verbose=10)
..
test_ip_basic (test_multiarray.TestFromBuffer) ... ok
test_multiarray.TestIO.test_ascii ... Segmentation fault

At this point I don't know if this is just a 64-bit issue; I'm
trying to look into it but 32-bit building for 10.6 was
unintentionally crippled in the 2.6.x series and 2.7a3; it
should be fixed in the next 2.7 release and in 2.6.5.

I can also verify that this segfault bug remains:

http://projects.scipy.org/numpy/ticket/1345

Dealing with it has been postponed since it affects 2.7 which
isn't due out for a few months.  However, 2.6.5rc1 is scheduled
for today (I don't see it yet!), with final in 2 weeks; it may
be worth seeing if these issues will appear in 2.6.5.

BTW:  The current NumPy and SciPy SVN (r8270, r6250) install
successfully with 64-bit Py-2.6.4 on Snow Leopard; the
NumPy tests are fine; the SciPy tests have many errors but
at least they no longer segfault.  I'll report further in
another thread; here it's just to point out that the issues
above do not affect 64-bit 2.6.4.

-Tom



-------------------------------------------------
This mail sent through IMP: http://horde.org/imp/


More information about the NumPy-Discussion mailing list