[Numpy-discussion] f2py compiler version errors

Pearu Peterson pearu.peterson@gmail....
Wed Mar 17 16:11:35 CDT 2010


Hi,
You are running rather old numpy version (1.0.1).
Try upgrading numpy as at least recent numpy from svn detects
this compiler fine.
Regards,
Pearu

Peter Brady wrote:
> Hello all,
> 
> The version of f2py that's installed on our system doesn't appear to 
> handle version numbers correctly.  I've attached the relevant output of 
> f2py below:
> 
>     customize IntelFCompiler
>     Couldn't match compiler version for 'Intel(R) Fortran Intel(R) 64
>     Compiler Professional for applications running on Intel(R) 64,
>     Version 11.0    Build 20090318 \nCopyright (C) 1985-2009 Intel
>     Corporation.  All rights reserved.\nFOR NON-COMMERCIAL USE ONLY\n\n
>     Intel Fortran 11.0-1578'
>     IntelFCompiler instance properties:
>       archiver        = ['ar', '-cr']
>       compile_switch  = '-c'
>       compiler_f77    =
>     ['/opt/intel/Compiler/11.0/083/bin/intel64/ifort', '-
>                         72', '-w90', '-w95', '-KPIC', '-cm', '-O3',
>     '-unroll', '-
>                         tpp7', '-xW', '-arch SSE2']
>       compiler_f90    =
>     ['/opt/intel/Compiler/11.0/083/bin/intel64/ifort', '-
>                         FR', '-KPIC', '-cm', '-O3', '-unroll', '-tpp7',
>     '-xW', '-
>                         arch SSE2']
>       compiler_fix    =
>     ['/opt/intel/Compiler/11.0/083/bin/intel64/ifort', '-
>                         FI', '-KPIC', '-cm', '-O3', '-unroll', '-tpp7',
>     '-xW', '-
>                         arch SSE2']
>       libraries       = []
>       library_dirs    = []
>       linker_so       =
>     ['/opt/intel/Compiler/11.0/083/bin/intel64/ifort', '-
>                         shared', '-tpp7', '-xW', '-arch SSE2']
>       object_switch   = '-o '
>       ranlib          = ['ranlib']
>       version         = None
>       version_cmd     =
>     ['/opt/intel/Compiler/11.0/083/bin/intel64/ifort', '-FI
>                         -V -c /tmp/tmpx6aZa8__dummy.f -o
>     /tmp/tmpx6aZa8__dummy.o']
> 
> 
> The output of f2py is:
> 
>     Version:     2_3473
>     numpy Version: 1.0.1
>     Requires:    Python 2.3 or higher.
>     License:     NumPy license (see LICENSE.txt in the NumPy source code)
>     Copyright 1999 - 2005 Pearu Peterson all rights reserved.
>     http://cens.ioc.ee/projects/f2py2e/
> 
> 
> We're running 64bit linux with python 2.4.  How do I make this work?
> 
> thanks,
> Peter.
>  
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion


More information about the NumPy-Discussion mailing list