[Numpy-discussion] np.resize differs from ndarray.resize

Alan G Isaac aisaac@american....
Fri Mar 19 11:38:58 CDT 2010


On 3/18/2010 4:56 AM, Sebastian Haase wrote:
> How would people feel about unifying the function vs. the method behavior ?
> One could add an addition option like
> `repeat` or `fillZero`.
> One could (at first !?) keep opposite defaults to not change the
> current behavior.
> But this way it would be most visible and clear what is going on.


The current situation is confusing.
I therefore hope that one of two things will happen.

- unification (probably with a `fill` option, with a default
of None that produces the function's behavior but that can
be give any numerical value (not just 0)), or
- eliminate the method

Thanks,
Alan


More information about the NumPy-Discussion mailing list