[Numpy-discussion] Array bug with character (regression from 1.4.0)

Charles R Harris charlesr.harris@gmail....
Sun Mar 21 18:03:44 CDT 2010


On Sun, Mar 21, 2010 at 4:29 PM, Pauli Virtanen <pav@iki.fi> wrote:

> su, 2010-03-21 kello 16:13 -0600, Charles R Harris kirjoitti:
> > I was wondering if this was related to Michael's fixes for
> > character arrays? A little bisection might help localize the problem.
>
> It's a bug I introduced in r8144... I forgot one *can* assign strings to
> 0-d arrays, and strings are indeed one sequence type.
>
> I'm going to back that changeset out, since it was only a cosmetic fix.
> That particular part of code needs some cleanup (it's a bit too hairy if
> things like this can slip), but I don't have the time at the moment to
> come up with a more complete fix.
>
>
Lots of the code needs some cleanup ;) The first step was to reformat it --
still ongoing, I've got changes on hold for after the release -- and break
it up into smaller files with some similarity of function. At some point the
code needs to be documented and some macros relaced with inline functions.
All macros that implement jumps should be removed and replaced by something
more transparent. I'd also like to see some of the "policy" type stuff move
up to cython, which should be easier to document and understand, not to
mention making for a cleaner interface to Python. So on and so on... We
could use a few more developers, especially with David getting a real job.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100321/fb24b96c/attachment.html 


More information about the NumPy-Discussion mailing list