[Numpy-discussion] Path to numpy installation

Robert Kern robert.kern@gmail....
Tue Nov 2 09:39:07 CDT 2010


On Tue, Nov 2, 2010 at 03:31, Juanjo Gomez Navarro
<juanjo.gomeznavarro@gmail.com> wrote:
>  Ok, so in your opinion I have two independent python installations? That's
> possible...

It's certain.

> The problem is that I want to use ipython, and this interpreter
> seems to take the wrong version by default...

That just means that you used the system Python to install ipython.
Put the /Library/Frameworks/.../bin at the front of your $PATH like I
explained before and reinstall IPython and numpy and all of the other
packages you want to use using that python executable. Double-check by
executing

$ which python
/Library/Frameworks/Python.framework/Versions/Current/bin/python

> Do you think it is safe just to delete the folder
> /System/Library/Frameworks/Python.framework to «uninstall» the wrong
> version?

No! Do not touch that! It is used by OS X.

-- 
Robert Kern

"I have come to believe that the whole world is an enigma, a harmless
enigma that is made terrible by our own mad attempt to interpret it as
though it had an underlying truth."
  -- Umberto Eco


More information about the NumPy-Discussion mailing list