[Numpy-discussion] Python2.7 version check for OSX numpy installer (please Test)

Ralf Gommers ralf.gommers@googlemail....
Tue Nov 9 18:18:50 CST 2010


Hi Vincent,

On Wed, Nov 10, 2010 at 1:03 AM, Vincent Davis <vincent@vincentdavis.net> wrote:
> No need to actualy install, You should get an error right away if you do not
> have both.
> /Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7
> /Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7-32
> If you have python-2.7-macosx10.5.dmg installed or built python2.7 for both
> 32 and 64 bit it should work (let you install)
> If you have python-2.7-macosx10.3.dmg installed it should not. It will fail
> to find /Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7-32 I
> think :-)
> Should this check be a warning or prevent install?

I'd say warning.

> The installer is numpy-1.5.1rc2-py2.7-python.org-macosx10.5
> I should have a numpy-1.5.1rc2-py2.7-python.org-macosx10.3 ready for testing
> later.
> http://dl.dropbox.com/u/1340248/1-nov%209%202010/numpy1.5.1rc2-Py2.7-32-64-test-python-version.dmg
>
If you propose a patch it would be helpful if you send a github link
to the list, or at least a diff.

BTW, Dropbox seems to be blocked in China, so it would help me a lot
if you could put binaries on your own site.

Cheers,
Ralf


More information about the NumPy-Discussion mailing list