[Numpy-discussion] Help building numpy

Ian Goodfellow goodfellow.ian@gmail....
Fri Oct 8 09:40:50 CDT 2010


Is there a log file I should post or do you just mean to capture everything
that setup.py prints to stdout?

On Fri, Oct 8, 2010 at 10:06 AM, Benjamin Root <ben.root@ou.edu> wrote:

> On Fri, Oct 8, 2010 at 8:47 AM, Ian Goodfellow <goodfellow.ian@gmail.com>wrote:
>
>> Can anyone explain how to get numpy to recognize atlas? I have atlas built
>> and installed, and I put what I thought should be sufficient, based on
>> numpy's INSTALL.TXT, to make numpy use atlas in my site.cfg then ran python
>> setup.py install. The resulting build is incredibly slow. Multiplying a
>> 1,000 x 1,000 matrix takes 8 seconds. The default packages take .8 . On a
>> computer at work with a similar but slower cpu to mine, it only takes .2, so
>> I know I should be able to get a lot more speed out of numpy.
>>
>> This is my site.cfg:
>>
>> [atlas]
>> atlas_libs = lapack, f77blas, cblas, atlas
>>
>> [DEFAULT]
>> library_dirs = /usr/local/atlas/lib
>> include_dir = /usr/local/atlas/include
>>
>> Thanks in advance,
>> Ian
>>
>>
> Ian, it would be very helpful if you could post the output from the build
> of numpy.  That log can tell us whether it found the libraries or not when
> building.
>
> Ben Root
>
>
> _______________________________________________
> NumPy-Discussion mailing list
> NumPy-Discussion@scipy.org
> http://mail.scipy.org/mailman/listinfo/numpy-discussion
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20101008/a9d79f4f/attachment.html 


More information about the NumPy-Discussion mailing list