[Numpy-discussion] Schedule for 1.5.1?

Charles R Harris charlesr.harris@gmail....
Fri Oct 8 11:48:14 CDT 2010


On Fri, Oct 8, 2010 at 10:37 AM, <josef.pktd@gmail.com> wrote:

> On Fri, Oct 8, 2010 at 12:21 PM, Charles R Harris
> <charlesr.harris@gmail.com> wrote:
> >
> >
> > On Fri, Oct 8, 2010 at 10:12 AM, <josef.pktd@gmail.com> wrote:
> >>
> >> On Fri, Oct 8, 2010 at 11:11 AM, Charles R Harris
> >> <charlesr.harris@gmail.com> wrote:
> >> >
> >> >
> >> > On Thu, Oct 7, 2010 at 8:16 AM, Ralf Gommers
> >> > <ralf.gommers@googlemail.com>
> >> > wrote:
> >> >>
> >> >>
> >> >> On Thu, Oct 7, 2010 at 10:00 PM, Pierre GM <pgmdevlist@gmail.com>
> >> >> wrote:
> >> >>>
> >> >>> Just asking,
> >> >>> Should I backport some bugs that were corrected in 2.0 for numpy.ma?
> >> >>> I
> >> >>> don't have any particular in mind, but I'm sure there must be
> some...
> >> >>>
> >> >> That would be helpful. Please backport any bug fixes that you think
> are
> >> >> important.
> >> >>
> >> >
> >> > IIRC, there was also a fix that Josef wanted in one of the stats
> >> > functions
> >> > before 1.5 but I don't remember which. Josef?
> >>
> >> Not sure, The only things that I remember right now is that Alan
> >> wanted to have ddof instead of bias in cov for consistency in names
> >> across functions, and the usual
> >>
> >> >>> np.nansum([])
> >> 1.#QNAN
> >> >>> np.nansum([np.nan])
> >> 1.#QNAN
> >>
> >> Both will change current behavior and might need a depreciation cycle.
> >>
> >> I have to see if a search through the mailing list turns something up.
> >>
> >
> > I think it was something about Pareto...
>
> Ok I remember, Pareto is actually Lomax or Pareto second kind, and
> should be renamed. The proposal was to rename the current pareto to
> pareto2 and create a new pareto that corrects location by one.
>
> In the meantime I discovered that Lomax is actually nicer to work with
> than Pareto one, so it's mainly a question of terminology/names and
> documentation. Just calling it pareto is very misleading.
>
>
That doesn't sound like something for 1.5.1. Can you think through the
naming issue and open a ticket so we can start rationalizing this for 2.0?
I'm thinking having pareto1 and lomax, or maybe pareto1 and pareto2, and
deprecating plain old pareto may be the way to go.

Chuck
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20101008/80a7b923/attachment.html 


More information about the NumPy-Discussion mailing list