[Numpy-discussion] Schedule for 1.5.1?

Pauli Virtanen pav@iki...
Fri Oct 8 12:10:10 CDT 2010


Fri, 08 Oct 2010 10:48:14 -0600, Charles R Harris wrote:
> On Fri, Oct 8, 2010 at 10:37 AM, <josef.pktd@gmail.com> wrote:
[clip]
>> Ok I remember, Pareto is actually Lomax or Pareto second kind, and
>> should be renamed. The proposal was to rename the current pareto to
>> pareto2 and create a new pareto that corrects location by one.
>>
>> In the meantime I discovered that Lomax is actually nicer to work with
>> than Pareto one, so it's mainly a question of terminology/names and
>> documentation. Just calling it pareto is very misleading.
>
> That doesn't sound like something for 1.5.1. Can you think through the
> naming issue and open a ticket so we can start rationalizing this for
> 2.0? I'm thinking having pareto1 and lomax, or maybe pareto1 and
> pareto2, and deprecating plain old pareto may be the way to go.

The documentation bit can be done, however, if there's a plan how to deal 
with it.

-- 
Pauli Virtanen



More information about the NumPy-Discussion mailing list