[Numpy-discussion] Matlab IO Warning in mio5.py

Ralf Gommers ralf.gommers@googlemail....
Mon Sep 27 08:46:42 CDT 2010


On Mon, Sep 27, 2010 at 12:07 PM, Charles R Harris <
charlesr.harris@gmail.com> wrote:

> > On Sun, Sep 26, 2010 at 11:03 PM, Ben Longstaff <longstaff2009@gmail.com>
>> wrote:
>>
>> >>> > Warning Message
>> >>> > C:\Python26\lib\site-packages\scipy\io\matlab\mio5.py:90:
>> >>> > RuntimeWarning:
>> >>> > __builtin__.file size changed, may indicate binary incompatibility
>> >>> >   from mio5_utils import VarReader5
>> >>> >
>> >>> > Hello, World!
>> >>>
>> >>> Which numpy and scipy versions are you using? e.g. scipy.__version__
>> >>> np.__version__
>> >>>
>> >>> This looks like a warning from cython, but the versions are still
>> >>> binary compatible, and there shouldn't be any problems.
>> >>> (with all numpy except 1.4.0 and 2.x in repository)
>> >>>
>>
>
> Didn't Ralph catch the warnings on import for the released binaries? Maybe
> he missed one. Also, I don't recall seeing seeing that one before, not that
> it is necessarily a problem.
>

Hmm, missed this one, also can't reproduce it on either XP or OS X with the
same numpy/scipy versions. If these warnings are platform-dependent
shouldn't that be considered a Cython bug?

Related commits are r6331 and r6512 in scipy.

Ralf
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20100927/9ccaeac2/attachment.html 


More information about the NumPy-Discussion mailing list