[Numpy-discussion] current numpy in python 2.5 ?

Warren Weckesser warren.weckesser@enthought....
Tue Feb 1 09:22:27 CST 2011


On Tue, Feb 1, 2011 at 9:16 AM, Charles R Harris
<charlesr.harris@gmail.com>wrote:

>
>
> On Tue, Feb 1, 2011 at 8:02 AM, Mark Sienkiewicz <sienkiew@stsci.edu>wrote:
>
>> Hi,
>>
>> I looked on the web site, but I couldn't find a list of python versions
>> that numpy expects to work on.  Is the trunk still expected to work in
>> Python 2.5 ?
>>
>> I'm asking because it doesn't, but I don't want to file a bug report if it
>> is not expected to.  The problem shows up when I run numpy.test():
>>
>>  File "/usr/stsci/pyssgdev/2.5.4/numpy/testing/utils.py", line 619
>>    except ValueError as e:
>>                       ^
>> SyntaxError: invalid syntax
>>
>>
> Python >= 2.4 is supported, so using the new exception syntax is a bug.
> Please open a ticket.
>
>

That's from a very recent commit:


https://github.com/numpy/numpy/commit/c4a556e1fcdede5fe366e4373a7f2dc802a0e898#diff-7

and as Chuck says, it is a bug, because numpy must support python 2.4.

Warren
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.scipy.org/pipermail/numpy-discussion/attachments/20110201/240c998b/attachment.html 


More information about the NumPy-Discussion mailing list