[Numpy-discussion] Please keep Numpy master working on Py3

David david@silveregg.co...
Tue Feb 1 23:49:37 CST 2011


On 02/02/2011 01:53 PM, David wrote:
> On 02/02/2011 08:58 AM, Pauli Virtanen wrote:
>> Hi,
>>
>> The master branch did not build today on Python 3. Please make sure that
>> your code works correctly also on Python 3, before pushing it.
>>
>>       ***
>>
>> I mostly fixed the stuff for now, mostly just the usual bytes vs unicode.
>>
>> On Python 3, the tests however give two non-obvious failures -- I'm not
>> sure if it's just a matter of the raised exception having a different
>> type on Py2 vs Py3, or if it reflects something going wrong. Mark, do you
>> have ideas?
>
> Following the merge on Mark's code, I am stlightly concerned about the
> dependency between ufunc and multiarray (i.e. ufunc include header in
> multiarray).
>
> In the meantime, I put the relevant header in numpy/core/src/private, to
> make the dependency clearer.

Following that argument, there are other unwanted dependencies between 
multiarray and ufunc, causing circular dependencies. I don't think they 
were there before, and it makes building numpy with a dependency-based 
tool like scons or waf extremely difficult.

cheers,

David


More information about the NumPy-Discussion mailing list