[Numpy-discussion] numpy docs dependency problem in Ubuntu

Jouni K. Seppänen jks@iki...
Fri Feb 11 09:18:58 CST 2011


[Crossposting to matplotlib devel list]

Robert Kern <robert.kern@gmail.com> writes:

> On Thu, Feb 10, 2011 at 11:22, Barry Warsaw <barry@python.org> wrote:
>
>> Here's the problem: for Ubuntu, we've had to disable the building of
>> the numpy documentation package, because its dependencies violate
>> Ubuntu policy.  Numpy is in our "main" archive but the documentation
>> depends on python-matplotlib, which lives in our "universe"
>> archive.  Such cross archive dependencies break the build.
>>
>> We can't put python-matplotlib in main because of *its* dependencies.
>
> As a digression, I think the python-matplotlib dependencies could be
> significantly reduced. For a number of use cases (this is one of them,
> but there are others), you don't need any GUI backend. Independent of
> this issue, it would be great to be able to install python-matplotlib
> in a headless server environment without pulling in all of those GUI
> bits. Looking at the list of the hard dependencies, I don't understand
> why half of them are there.
>
>   http://packages.ubuntu.com/natty/python/python-matplotlib

Would it make sense to split out each interactive backend to its own
Ubuntu package, e.g. python-matplotlib-tk, etc? Each of these would
depend on the relevant toolkit packages, and python-matplotlib would
have a much shorter list of dependencies.

-- 
Jouni K. Seppänen
http://www.iki.fi/jks



More information about the NumPy-Discussion mailing list