[Numpy-discussion] numpy docs dependency problem in Ubuntu

Pauli Virtanen pav@iki...
Fri Feb 11 10:07:25 CST 2011


Fri, 11 Feb 2011 10:40:57 -0500, Barry Warsaw wrote:
[clip]
> Neither will be acceptable I think.  Prebuilt by upstream won't fly
> for Debian because they'd want the source and build process, and I
> don't see a feasible way for them to be prebuilt by Ubuntu that's any
> different than the current build process (which fails because of
> the cross-archive issue).
> 
> Do you think it would be feasible for numpy to produce two tarballs -
> one with just the code and the other with just the docs?

That's exactly what I meant by "pre-built by upstream". We currently
*do* have separate HTML doc packages, built for each release; cf. 
http://docs.scipy.org/

In the future, we can ship the HTML doc packages in the same place as
the source packages, so that they are easier to discover.

    ***

@Ralf or someone else with sourceforge permissions: would you mind
uploading

    http://docs.scipy.org/doc/numpy-1.5.x/numpy-html.zip

as numpy-doc-1.5.1.zip (or .tar.gz) on sourceforge?

-- 
Pauli Virtanen



More information about the NumPy-Discussion mailing list