[Numpy-discussion] numpy docs dependency problem in Ubuntu

Bruce Southey bsouthey@gmail....
Fri Feb 11 12:06:42 CST 2011


On 02/11/2011 11:50 AM, Pauli Virtanen wrote:
> Fri, 11 Feb 2011 11:34:16 -0600, Bruce Southey wrote:
> [clip]
>> I agree with Pauli, if Ubuntu wants the user to be able build the
>> documentation then Ubuntu would have to create a special package with
>> just the numpy documentation that includes the necessary dependencies
>> (including numpy, matlibplot and sphinx).
> The point is that the Ubuntu build servers cannot build the
> documentation, because matplotlib is not available at build time. (First,
> because matplotlib depends circularly on Numpy, and second, since by
> policy Numpy build cannot depend on matplotlib as Numpy is in "main" and
> matplotlib in "universe".)
If Ubuntu's different repositories are a problem then that is Ubuntu's 
own fault for putting the numpy and matplotlib in different repositories 
(that applies to other distros as well). Clearly someone did not do 
their homework before doing so. However, I do not know that Ubuntu's 
numpy package also has the sphinx dependency that is also required here. 
But I am sure that you would take patches from Ubuntu that allowed the 
building of documentation without other dependencies than numpy and sphinx.

> I don't see other solutions apart from creating a separate source package
> from the contents of numpy/doc/*. However, I don't see very many reasons
> why we (as the Numpy upstream) should make this split, and why the
> Debian/Ubuntu packagers could not do it.
>
But that directory is still not sufficient for having the documentation 
alone.

Bruce
PS Yes, Robert and I also read the actual bug report which indicated 
what the real problem is.


More information about the NumPy-Discussion mailing list