[Numpy-discussion] numpy docs dependency problem in Ubuntu

Barry Warsaw barry@python....
Fri Feb 11 13:47:30 CST 2011


On Feb 11, 2011, at 05:50 PM, Pauli Virtanen wrote:

>The point is that the Ubuntu build servers cannot build the 
>documentation, because matplotlib is not available at build time. (First, 
>because matplotlib depends circularly on Numpy, and second, since by 
>policy Numpy build cannot depend on matplotlib as Numpy is in "main" and 
>matplotlib in "universe".)

Exactly so.

>I don't see other solutions apart from creating a separate source package 
>from the contents of numpy/doc/*. However, I don't see very many reasons 
>why we (as the Numpy upstream) should make this split, and why the 
>Debian/Ubuntu packagers could not do it.

I think what we would do is just build a new source package that refers to the
same upstream tarball as the code source package.  We'd just move the
documentation building rules to this new source package, remove them from the
code package and stick the doc package in universe.  This would require no
change for either upstream or Debian, and would solely be in Ubuntu.

The downside is that it probably means Ubuntu would more or less permanently
diverge from Debian for numpy, which would be unfortunate for many reasons.  I
can certainly appreciate that from both upstream's and Debian's perspective,
nothing is broken here and that Ubuntu must adjust.  If that's the best we can
do, so be it, but I'm hoping there is a solution out there that would allow us
to avoid either a divergence or providing Ubuntu users with a less than
complete documentation package.

Cheers,
-Barry
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
Url : http://mail.scipy.org/pipermail/numpy-discussion/attachments/20110211/e2d67706/attachment.bin 


More information about the NumPy-Discussion mailing list