[Numpy-discussion] numpy docs dependency problem in Ubuntu

Barry Warsaw barry@python....
Thu Feb 17 17:00:05 CST 2011


Hi Ralf,

On Feb 12, 2011, at 06:12 PM, Ralf Gommers wrote:

> Now that you're here to discuss Ubuntu packaging, can you tell us if you or
>another packager plan to include scipy 0.9.0 in Natty if it's released on
>time? Final release is planned for the weekend of 19/20 Feb.

Feature freeze for Natty is February 24th, so if the timing is *just right* it
may be possible.  Ideally, we'd get 0.9.0 into Debian right after scipy 0.9.0
is released, and then sync it to Ubuntu.  I don't have permission to upload to
Debian, so we'd have to coordinate that between upstream (you guys), Debian
Python Modules Team <python-modules-team@lists.alioth.debian.org>, and
Ubuntu.  If you remind me, I'll will try to facilitate that.

One question though: is 0.9.0 API and backward compatible with 0.8.0?  I see
we have a couple of dozen reverse dependencies on python-scipy, so if there's
any chance that 0.9.0 would break those dependencies, we may have to push that
off until Natty+1.  Here are a list of the reverse dependencies in Natty:

  spyder
  shogun-python-modular
  science-statistics
  science-numericalcomputation
  science-nanoscale-physics
  pytrainer
  python-symeig
  python-scitools
  python-scipy-dbg
  python-scikits-learn
  python-openopt
  python-nipype
  python-nipy
  python-nibabel
  python-networkx
  python-mvpa
  python-mdp
  python-matplotlib
  python-gastables
  psychopy
  model-builder
  mayavi2
  gvb
  gnuradio-utils

I can probably run a test build in a PPA for these packages, but the timing
will be tight.

Cheers,
-Barry
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 836 bytes
Desc: not available
Url : http://mail.scipy.org/pipermail/numpy-discussion/attachments/20110217/ab13ac79/attachment.bin 


More information about the NumPy-Discussion mailing list