[Numpy-discussion] Different behavior for astype('str') in numpy 1.5.1 vs 1.6.0?

Pauli Virtanen pav@iki...
Mon Feb 21 16:56:38 CST 2011


On Mon, 21 Feb 2011 16:03:43 -0500, Skipper Seabold wrote:
[clip]
> I had to reinstall scipy, matplotlib, etc. when I changed from 1.6.0
> back to 1.5.1.

Yes, it should be backward compatible (you should be able use binaries 
compiled with 1.5.1 on 1.6.0), but not forward compatible (binaries 
compiled with 1.6.0 won't work on 1.5.1).

> It also looked like the behavior of numpy.testing was different (Ie., I
> was getting failures for my tests that pass under 1.5.1 at the specified
> precision for assert_almost_equal), but this is a separate issue that
> I'll have to explore later.

Sure, tickets are welcome. The current unit test suite is probably not 
very complete, esp. for numpy.testing.

	Pauli



More information about the NumPy-Discussion mailing list