[Numpy-discussion] Numpy 1.6 schedule (was: Numpy 2.0 schedule)

Pauli Virtanen pav@iki...
Mon Mar 7 07:49:26 CST 2011


Mon, 07 Mar 2011 13:17:55 +0100, Francesc Alted wrote:
[clip]
>     from tables.utilsExtension import getPyTablesVersion, getHDF5Version
>   File "definitions.pxd", line 138, in init tables.utilsExtension
> (tables/utilsExtension.c:9238)
> ValueError: numpy.dtype has the wrong size, try recompiling
> 
> I've seen the same issue when NumPy jumped from 1.3.x to 1.4.1, forcing
> all the packages depending on NumPy to be recompiled to work with 1.4.1
> and higher.  Do we really want to repeat the experience with 1.5.x -->
> 1.6.x?

I got the impression that this unnecessary check was removed in newer 
Cython versions? If so, some of the existing code should not have this 
problem.

However, the size of PyArray_Descr does not seem to have changed between 
1.5.1 and the Git master. So I'm not sure why you see this error...

-- 
Pauli Virtanen



More information about the NumPy-Discussion mailing list