[Numpy-discussion] Numeric 24.2 incompatible with Windows7 SP1

Frank Conradie frank@qfin....
Mon Mar 7 12:19:09 CST 2011


Hi

I know Numeric 24.2 is really old and probably unsupported by now, but I 
thought it might be of interest that Service Pack 1 for Windows 7 has 
"broken" Numeric 24.2.

We have an old software product that uses Python 2.3 and Numeric 24.2, 
"frozen" using py2exe, and we started receiving reports from users 
recently that the software was failing upon launch. After investigation 
it became clear that the single commonality among the users was that 
they all recently installed SP1 for Windows 7, so we tried that 
ourselves, and sure enough, importing Numeric now causes this error:

Python 2.3.5 (#62, Feb  8 2005, 16:23:02) [MSC v.1200 32 bit (Intel)] on 
win32
Type "help", "copyright", "credits" or "license" for more information.
 >>> import Numeric
Traceback (most recent call last):
   File "<stdin>", line 1, in ?
   File "C:\python23\lib\site-packages\Numeric\Numeric.py", line 91, in ?
     import multiarray
ImportError: DLL load failed: The parameter is incorrect.

I will try and recompile Numeric 24.2 to see if this solves the problem, 
but I was wondering if anyone out there has any experience and/or 
comments on this?

Thanks!
Frank Conradie


More information about the NumPy-Discussion mailing list