[Numpy-discussion] [cython-users] errors with numpy 1.5.1

Robert Bradshaw robertwb@math.washington....
Tue Mar 8 02:12:35 CST 2011


On Fri, Mar 4, 2011 at 4:19 PM, Choy <matthew.iyer@gmail.com> wrote:
> Hello --
>
> I recently upgraded from python 2.6 -> 2.7, cython 0.13 -> 14.1, and
> numpy 1.4.1 -> 1.5.1.  Unfortunately, one of my cython modules no
> longer works.
>
> I tracked my bug and used the web to see that there is already a
> ticket for exact same bug with the new buffer interface in numpy
> 1.5.1.
>
> http://trac.cython.org/cython_trac/ticket/630
>
> This is precisely the bug I am observing.
>
> Let me know if there is an easy patch, or if a release is planned that
> addresses this in the near future.

Unfortunately, I don't think anyone's actively working on it right
now. It's probably a superficial fix for someone who knows NumPy and
Cython decently well, but I have no idea myself (not having looked
that deeply into it.) Does anyone know what the backwards incompatible
NumPy 1.4 -> 1.5 changes were?

- Robert


More information about the NumPy-Discussion mailing list